package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^"{,]+)\s*:\s*"([^"]*)",?`)
var str = `{type:"2",PvNum:"",Price:"1989",UploadSec:"",UploadTime:"",RemainNum:"123",SoldNum:"77",MaxBuyNum:"1", StockAttr:"颜色:留言颜色和快递", StockString:"0#颜色:留言颜色和快递~,19.890000,123,;"}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}