#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b[JEF]\d\d\b"
Local $sString = "Trade Unions: Objectives, Structure, and Effects J51" & @CRLF & _
"Trade and Labor Market Interactions F16,Wage Level and Structure; Wage Differentials J31" & @CRLF & _
"Trade and Labor Market Interactions F16,Wage Level and Structure; Wage Differentials J31" & @CRLF & _
"Trade Policy; International Trade Organizations F13" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")