re = /\b[JEF]\d\d\b/m
str = 'Trade Unions: Objectives, Structure, and Effects J51
Trade and Labor Market Interactions F16,Wage Level and Structure; Wage Differentials J31
Trade and Labor Market Interactions F16,Wage Level and Structure; Wage Differentials J31
Trade Policy; International Trade Organizations F13
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end