import Foundation
let pattern = #"\b[JEF]\d\d\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Trade Unions: Objectives, Structure, and Effects J51
Trade and Labor Market Interactions F16,Wage Level and Structure; Wage Differentials J31
Trade and Labor Market Interactions F16,Wage Level and Structure; Wage Differentials J31
Trade Policy; International Trade Organizations F13
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)