using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b[JEF]\d\d\b";
string input = @"Trade Unions: Objectives, Structure, and Effects J51
Trade and Labor Market Interactions F16,Wage Level and Structure; Wage Differentials J31
Trade and Labor Market Interactions F16,Wage Level and Structure; Wage Differentials J31
Trade Policy; International Trade Organizations F13
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}