const regex = /\b[JEF]\d\d\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b[JEF]\\d\\d\\b', 'gm')
const str = `Trade Unions: Objectives, Structure, and Effects J51
Trade and Labor Market Interactions F16,Wage Level and Structure; Wage Differentials J31
Trade and Labor Market Interactions F16,Wage Level and Structure; Wage Differentials J31
Trade Policy; International Trade Organizations F13
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}