package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b[JEF]\d\d\b`)
var str = `Trade Unions: Objectives, Structure, and Effects J51
Trade and Labor Market Interactions F16,Wage Level and Structure; Wage Differentials J31
Trade and Labor Market Interactions F16,Wage Level and Structure; Wage Differentials J31
Trade Policy; International Trade Organizations F13
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}