using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"/([^/]+)/?$";
string substitution = @"#\1";
string input = @"http://www.foo.com/fooparent/foochild
http://www.foo.com/fooparent/foochild/";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}