$re = '~/([^/]+)/?$~m';
$str = 'http://www.foo.com/fooparent/foochild
http://www.foo.com/fooparent/foochild/';
$subst = "#\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;