package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)/([^/]+)/?$`)
var str = `http://www.foo.com/fooparent/foochild
http://www.foo.com/fooparent/foochild/`
var substitution = "#\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}