const regex = new RegExp('/([^/]+)/?$', 'gm')
const str = `http://www.foo.com/fooparent/foochild
http://www.foo.com/fooparent/foochild/`;
const subst = `#\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);