use strict;
my $str = 'http://www.foo.com/fooparent/foochild
http://www.foo.com/fooparent/foochild/';
my $regex = qr~/([^/]+)/?$~mp;
my $subst = '#\\1';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";