import re
regex = re.compile(r"/([^/]+)/?$", flags=re.MULTILINE)
test_str = ("http://www.foo.com/fooparent/foochild\n"
"http://www.foo.com/fooparent/foochild/")
subst = "#\\1"
result = regex.sub(subst, test_str)
if result:
print(result)