re = /\/([^\/]+)\/?$/m
str = 'http://www.foo.com/fooparent/foochild
http://www.foo.com/fooparent/foochild/'
subst = '#\\1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result