using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"access_token=(\w+).*user_id=(\d+)";
string input = @"#access_token=699600f84569c1686d39fbd3a6511116b3cb6bbf5169d05c5be384355e381080ea033a7576e05efaf8&expires_in=86400&user_id=2693842";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}