package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`access_token=(\w+).*user_id=(\d+)`)
var str = `#access_token=699600f84569c1686d39fbd3a6511116b3cb6bbf5169d05c5be384355e381080ea033a7576e05efaf8&expires_in=86400&user_id=2693842`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}