const regex = /access_token=(\w+).*user_id=(\d+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('access_token=(\\w+).*user_id=(\\d+)', '')
const str = `#access_token=699600f84569c1686d39fbd3a6511116b3cb6bbf5169d05c5be384355e381080ea033a7576e05efaf8&expires_in=86400&user_id=2693842`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}