use strict;
my $str = '#access_token=699600f84569c1686d39fbd3a6511116b3cb6bbf5169d05c5be384355e381080ea033a7576e05efaf8&expires_in=86400&user_id=2693842';
my $regex = qr/access_token=(\w+).*user_id=(\d+)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}