// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"access_token=(\w+).*user_id=(\d+)").unwrap();
let string = "#access_token=699600f84569c1686d39fbd3a6511116b3cb6bbf5169d05c5be384355e381080ea033a7576e05efaf8&expires_in=86400&user_id=2693842";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}