re = /access_token=(\w+).*user_id=(\d+)/
str = '#access_token=699600f84569c1686d39fbd3a6511116b3cb6bbf5169d05c5be384355e381080ea033a7576e05efaf8&expires_in=86400&user_id=2693842'
# Print the match result
str.match(re) do |match|
puts match.to_s
end