# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:\\/|-|\+|\:|^|\(|\)| ) ?(\d+)/ /gm;t' <<< "4/13/2022 2:20:03 pm from our side a more detailed analysis4 +7 (495) 797-8700 77-8282"