const regex = /(?:\/|-|\+|\:|^|\(|\)| ) ?(\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\\/|-|\\+|\\:|^|\\(|\\)| ) ?(\\d+)', 'gm')
const str = `4/13/2022 2:20:03 pm from our side a more detailed analysis4 +7 (495) 797-8700 77-8282`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);