use strict;
my $str = '4/13/2022 2:20:03 pm from our side a more detailed analysis4 +7 (495) 797-8700 77-8282';
my $regex = qr/(?:\/|-|\+|\:|^|\(|\)| ) ?(\d+)/mp;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";