package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\/|-|\+|\:|^|\(|\)| ) ?(\d+)`)
var str = `4/13/2022 2:20:03 pm from our side a more detailed analysis4 +7 (495) 797-8700 77-8282`
var substitution = " "
fmt.Println(re.ReplaceAllString(str, substitution))
}