using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^class ([\w]+)\([^)]+\):";
string input = @"class foo1(object):
bar1()
class foo2(object):
bar2()
class foo3(object):
bar3()";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}