$re = '/^class ([\w]+)\([^)]+\):/m';
$str = 'class foo1(object):
bar1()
class foo2(object):
bar2()
class foo3(object):
bar3()';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);