// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^class ([\w]+)\([^)]+\):").unwrap();
let string = "class foo1(object):
bar1()
class foo2(object):
bar2()
class foo3(object):
bar3()";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}