re = /^class ([\w]+)\([^)]+\):/m
str = 'class foo1(object):
bar1()
class foo2(object):
bar2()
class foo3(object):
bar3()'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end