package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^class ([\w]+)\([^)]+\):`)
var str = `class foo1(object):
bar1()
class foo2(object):
bar2()
class foo3(object):
bar3()`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}