import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^class ([\\w]+)\\([^)]+\\):";
final String string = "class foo1(object):\n"
+ " bar1()\n\n"
+ "class foo2(object):\n"
+ " bar2()\n\n"
+ "class foo3(object):\n"
+ " bar3()";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}