# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\w)\w+(?=\w{2}$)|(?<=^\w)\w+/***/gmu;t' <<< "Иванов Иван Иванович
Ли Иван Иванович
Петров Пётр Петрович"