#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mu)(?<=\w)\w+(?=\w{2}$)|(?<=^\w)\w+"
Local $sString = "Иванов Иван Иванович" & @CRLF & _
"Ли Иван Иванович" & @CRLF & _
"Петров Пётр Петрович"
Local $sSubst = "***"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)