import re
regex = re.compile(r"(?<=\w)\w+(?=\w{2}$)|(?<=^\w)\w+", flags=re.MULTILINE | re.UNICODE)
test_str = ("Иванов Иван Иванович\n"
"Ли Иван Иванович\n"
"Петров Пётр Петрович")
subst = "***"
result = regex.sub(subst, test_str)
if result:
print(result)