re = /(?<=\w)\w+(?=\w{2}$)|(?<=^\w)\w+/m
str = 'Иванов Иван Иванович
Ли Иван Иванович
Петров Пётр Петрович'
subst = '***'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result