$re = '/(?<=\w)\w+(?=\w{2}$)|(?<=^\w)\w+/mu';
$str = 'Иванов Иван Иванович
Ли Иван Иванович
Петров Пётр Петрович';
$subst = "***";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;