# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?=@(?!(IP1|IP2)))/#/gm;t' <<< "@hi
@IP1
some stuff here
@IP2"