#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?=@(?!(IP1|IP2)))"
Local $sString = "@hi" & @CRLF & _
"@IP1" & @CRLF & _
"some stuff here" & @CRLF & _
"@IP2"
Local $sSubst = "#"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)