use strict;
my $str = '@hi
@IP1
some stuff here
@IP2';
my $regex = qr/^(?=@(?!(IP1|IP2)))/mp;
my $subst = '#';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";