re = /^(?=@(?!(IP1|IP2)))/m
str = '@hi
@IP1
some stuff here
@IP2'
subst = '#'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result