using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=@(?!(IP1|IP2)))";
string substitution = @"#";
string input = @"@hi
@IP1
some stuff here
@IP2";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}