const regex = new RegExp('^(?=@(?!(IP1|IP2)))', 'gm')
const str = `@hi
@IP1
some stuff here
@IP2`;
const subst = `#`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);