$re = '/^(?=@(?!(IP1|IP2)))/m';
$str = '@hi
@IP1
some stuff here
@IP2';
$subst = "#";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;