# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*?([\w-]+)$/$1/gm;t' <<< "https://www.youtube.com/watch?v=K1CScQOj1dA
https://youtu.be/wIJ1sFrgMds
IISzG-sPUuo
"