import Foundation
let pattern = #".*?([\w-]+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
https://www.youtube.com/watch?v=K1CScQOj1dA
https://youtu.be/wIJ1sFrgMds
IISzG-sPUuo
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)