#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m).*?([\w-]+)$"
Local $sString = "https://www.youtube.com/watch?v=K1CScQOj1dA" & @CRLF & _
"https://youtu.be/wIJ1sFrgMds" & @CRLF & _
"IISzG-sPUuo" & @CRLF & _
""
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)