// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).*?([\w-]+)$").unwrap();
let string = "https://www.youtube.com/watch?v=K1CScQOj1dA
https://youtu.be/wIJ1sFrgMds
IISzG-sPUuo
";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}