re = /.*?([\w-]+)$/m
str = 'https://www.youtube.com/watch?v=K1CScQOj1dA
https://youtu.be/wIJ1sFrgMds
IISzG-sPUuo
'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result