$re = '/.*?([\w-]+)$/m';
$str = 'https://www.youtube.com/watch?v=K1CScQOj1dA
https://youtu.be/wIJ1sFrgMds
IISzG-sPUuo
';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;