#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:"[^"]*"[^"]*)*?\"{1}([^"]*?([']{1,})[^"]*?)\""
Local $sString = "If you place a quote there: () it should not be detected, but if "you place a quote there: (()) " it should be detected , apparently if there is no quote between double-quotes elsewhere and there are some outside double-quotes ex: () those outside are detected and we do not want that." & @CRLF & _
"" & @CRLF & _
"My problem is that I want to match single quotes using a regex, but I only want to do so if they are being quotes : between double-quotes, like so : "(())" add/remove single quotes between parenthesis to test..." & @CRLF & _
"" & @CRLF & _
"(()) = should match" & @CRLF & _
"() = should not match"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")