using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:""[^""]*""[^""]*)*?\""{1}([^""]*?([']{1,})[^""]*?)\""";
string input = @"If you place a quote there: () it should not be detected, but if ""you place a quote there: (()) "" it should be detected , apparently if there is no quote between double-quotes elsewhere and there are some outside double-quotes ex: () those outside are detected and we do not want that.
My problem is that I want to match single quotes using a regex, but I only want to do so if they are being quotes : between double-quotes, like so : ""(())"" add/remove single quotes between parenthesis to test...
(()) = should match
() = should not match";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}